CVE-2009-1309

NameCVE-2009-1309
DescriptionMozilla Firefox before 3.0.9, Thunderbird, and SeaMonkey do not properly implement the Same Origin Policy for (1) XMLHttpRequest, involving a mismatch for a document's principal, and (2) XPCNativeWrapper.toString, involving an incorrect __proto__ scope, which allows remote attackers to conduct cross-site scripting (XSS) attacks and possibly other attacks via a crafted document.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1797-1
NVD severitymedium (attack range: remote, user-initiated)
Debian/oldoldstablepackage kompozer is vulnerable; however, the security impact is unimportant.
Debian/oldstablenot vulnerable.
Debian/stablenot known to be vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
kompozer (PTS)squeeze1:0.8~b3.dfsg.1-0.1vulnerable
xulrunner (PTS)wheezy (security), wheezy24.8.1esr-2~deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kompozersource(unstable)(unfixed)unimportant
xulrunnersource(unstable)1.9.0.9-1medium
xulrunnersourceetch(unfixed)end-of-life
xulrunnersourcelenny1.9.0.9-0lenny2mediumDSA-1797-1

Notes

[etch] - xulrunner <end-of-life> (Etch Packages no longer covered by security support)
kompozer shares the browser engine with Firefox, but JavaScript is not enabled

Search for package or bug name: Reporting problems