CVE-2009-1364

NameCVE-2009-1364
DescriptionUse-after-free vulnerability in the embedded GD library in libwmf 0.2.8.4 allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted WMF file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1796-1
NVD severityhigh (attack range: remote)
Debian Bugs526434

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libwmf (PTS)wheezy0.2.8.4-10.3+deb7u1fixed
wheezy (security)0.2.8.4-10.3+deb7u2fixed
jessie0.2.8.4-10.3+deb8u2fixed
jessie (security)0.2.8.4-10.3+deb8u1fixed
stretch0.2.8.4-10.6fixed
buster, sid0.2.8.4-12fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libwmfsource(unstable)0.2.8.4-6.1low526434
libwmfsourceetch0.2.8.4-2+etch1highDSA-1796-1
libwmfsourcelenny0.2.8.4-6+lenny1highDSA-1796-1

Search for package or bug name: Reporting problems