CVE-2009-1384

NameCVE-2009-1384
Descriptionpam_krb5 2.2.14 through 2.3.4, as used in Red Hat Enterprise Linux (RHEL) 5, generates different password prompts depending on whether the user account exists, which allows remote attackers to enumerate valid usernames.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libpam-krb5 (PTS)wheezy4.6-1fixed
jessie4.6-3fixed
buster, sid, stretch4.7-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libpam-krb5source(unstable)(not affected)

Notes

- libpam-krb5 <not-affected> (different code base than Debian's libpam-krb5)

Search for package or bug name: Reporting problems