CVE-2009-1438

NameCVE-2009-1438
DescriptionInteger overflow in the CSoundFile::ReadMed function (src/load_med.cpp) in libmodplug before 0.8.6, as used in gstreamer-plugins, TTPlayer, and other products, allows context-dependent attackers to execute arbitrary code via a MED file with a crafted (1) song comment or (2) song name, which triggers a heap-based buffer overflow, as exploited in the wild in August 2008.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1850-1, DSA-1851-1
NVD severityhigh (attack range: remote)
Debian Bugs526657, 527075, 527076
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gst-plugins-bad0.10 (PTS)squeeze0.10.19-2fixed
wheezy0.10.23-7.1+deb7u1fixed
jessie, sid0.10.23-7.4fixed
libmodplug (PTS)squeeze (security), squeeze1:0.8.8.1-1+squeeze2+git20130828fixed
wheezy, wheezy (security)1:0.8.8.4-3+deb7u1+git20130828fixed
jessie, sid1:0.8.8.4-4.1fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gst-plugins-bad0.10source(unstable)0.10.10.2-1high527075
gst-plugins-bad0.10sourceetch0.10.3-3.1+etch3highDSA-1851-1
gst-plugins-bad0.10sourcelenny0.10.7-2+lenny2highDSA-1851-1
libmodplugsource(unstable)1:0.8.7-1low526657, 527076
libmodplugsourceetch1:0.7-5.2+etch1highDSA-1850-1
libmodplugsourcelenny1:0.8.4-1+lenny1highDSA-1850-1

Notes

gstreamer in unstable dynamically linked to external libmodplug

Search for package or bug name: Reporting problems