CVE-2009-1513

NameCVE-2009-1513
DescriptionBuffer overflow in the PATinst function in src/load_pat.cpp in libmodplug before 0.8.7 allows user-assisted remote attackers to cause a denial of service and possibly execute arbitrary code via a long instrument name.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1850-1
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs526084
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gst-plugins-bad0.10 (PTS)squeeze0.10.19-2fixed
wheezy0.10.23-7.1+deb7u1fixed
jessie, sid0.10.23-7.4fixed
libmodplug (PTS)squeeze (security), squeeze1:0.8.8.1-1+squeeze2+git20130828fixed
wheezy, wheezy (security)1:0.8.8.4-3+deb7u1+git20130828fixed
jessie, sid1:0.8.8.4-4.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gst-plugins-bad0.10source(unstable)(not affected)
libmodplugsource(unstable)1:0.8.7-1medium526084
libmodplugsourceetch1:0.7-5.2+etch1mediumDSA-1850-1
libmodplugsourcelenny1:0.8.4-1+lenny1mediumDSA-1850-1

Notes

- gst-plugins-bad0.10 <not-affected> (Vulnerable code not present; bug #527077)
[etch] - libmodplug <not-affected> (Vulnerable code not present)
gst-plugins-bad0.10 in testing and unstable builds against an external libmodplug.

Search for package or bug name: Reporting problems