CVE-2009-1904

NameCVE-2009-1904
DescriptionThe BigDecimal library in Ruby 1.8.6 before p369 and 1.8.7 before p173 allows context-dependent attackers to cause a denial of service (application crash) via a string argument that represents a large number, as demonstrated by an attempted conversion to the Float data type.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1860-1
NVD severitymedium (attack range: remote)
Debian Bugs532689, 575778

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby1.8 (PTS)wheezy1.8.7.358-7.1+deb7u3fixed
wheezy (security)1.8.7.358-7.1+deb7u4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby1.8source(unstable)1.8.7.173-1low532689
ruby1.8sourceetch1.8.5-4etch5mediumDSA-1860-1
ruby1.8sourcelenny1.8.7.72-3lenny1mediumDSA-1860-1
ruby1.9source(unstable)(unfixed)medium575778
ruby1.9sourceetch1.9.0+20060609-1etch5mediumDSA-1860-1
ruby1.9sourcelenny1.9.0.2-9lenny1mediumDSA-1860-1

Notes

http://www.ruby-lang.org/en/news/2009/06/09/dos-vulnerability-in-bigdecimal/

Search for package or bug name: Reporting problems