CVE-2009-2084

NameCVE-2009-2084
DescriptionSimple Linux Utility for Resource Management (SLURM) 1.2 and 1.3 before 1.3.14 does not properly set supplementary groups before invoking (1) sbcast from the slurmd daemon or (2) strigger from the slurmctld daemon, which might allow local SLURM users to modify files and gain privileges.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1776-1
NVD severityhigh
Debian Bugs524980

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
slurm-llnl (PTS)stretch16.05.9-1+deb9u4fixed
stretch (security)16.05.9-1+deb9u2fixed
buster, buster (security)18.08.5.2-1+deb10u1fixed
bullseye, sid19.05.5-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
slurm-llnlsource(unstable)1.3.15-1524980
slurm-llnlsourcelenny1.3.6-1lenny3

Search for package or bug name: Reporting problems