CVE-2009-2174

NameCVE-2009-2174
DescriptionGUPnP 0.12.7 allows remote attackers to cause a denial of service (crash) via an empty (1) subscription or (2) control message.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs534594

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gupnp (PTS)stretch1.0.1-1fixed
stretch (security)1.0.1-1+deb9u1fixed
buster1.0.5-0+deb10u1fixed
bullseye1.2.4-1fixed
bookworm, sid1.4.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gupnpsource(unstable)0.12.6-3.1low534594

Notes

[etch] - gupnp <no-dsa> (Minor issue)
[lenny] - gupnp <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems