CVE-2009-2463

NameCVE-2009-2463
DescriptionMultiple integer overflows in the (1) PL_Base64Decode and (2) PL_Base64Encode functions in nsprpub/lib/libc/src/base64.c in Mozilla Firefox before 3.0.12, Thunderbird before 2.0.0.24, and SeaMonkey before 1.1.19 allow remote attackers to cause a denial of service (memory corruption and application crash) or possibly execute arbitrary code via unspecified vectors that trigger buffer overflows.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1931-1, DSA-2025-1
NVD severityhigh (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icedove (PTS)squeeze, squeeze (security)3.0.11-1+squeeze15fixed
wheezy31.3.0-1~deb7u1fixed
wheezy (security)31.8.0-1~deb7u1fixed
jessie31.7.0-1~deb8u1fixed
jessie (security)31.8.0-1~deb8u1fixed
stretch31.7.0-1fixed
sid38.1.0-1fixed
nspr (PTS)squeeze, squeeze (security)4.8.6-1+squeeze1fixed
squeeze (lts)4.8.6-1+squeeze2fixed
wheezy (security), wheezy2:4.9.2-1+deb7u2fixed
jessie2:4.10.7-1fixed
stretch2:4.10.9-1fixed
sid2:4.10.9-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
icedovesource(unstable)3.0~rc2-2high
icedovesourcelenny2.0.0.24-0lenny1highDSA-2025-1
nsprsource(unstable)4.8.2-1high
nsprsourceetch(unfixed)end-of-life
nsprsourcelenny4.7.1-5highDSA-1931-1

Notes

[etch] - nspr <end-of-life> (Mozilla packages from oldstable no longer covered by security support)

Search for package or bug name: Reporting problems