CVE-2009-2473

NameCVE-2009-2473
Descriptionneon before 0.28.6, when expat is used, does not properly detect recursion during entity expansion, which allows context-dependent attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document containing a large number of nested entity references, a similar issue to CVE-2003-1564.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
neon27 (PTS)buster0.30.2-3fixed
bullseye0.31.2-1fixed
bookworm0.32.5-1fixed
trixie0.33.0-1fixed
sid0.33.0-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
neonsourceetch(not affected)
neonsource(unstable)(unfixed)
neon26source(unstable)(not affected)
neon27source(unstable)(not affected)

Notes

- neon27 <not-affected> (neon27 is compiled to use libxml2 instead of expat)
- neon26 <not-affected> (neon26 is compiled to use libxml2 instead of expat)
[etch] - neon <not-affected> (neon is compiled to use libxml2 instead of expat)

Search for package or bug name: Reporting problems