CVE-2009-2820

NameCVE-2009-2820
DescriptionThe web interface in CUPS before 1.4.2, as used on Apple Mac OS X before 10.6.2 and other platforms, does not properly handle (1) HTTP headers and (2) HTML templates, which allows remote attackers to conduct cross-site scripting (XSS) attacks and HTTP response splitting attacks via vectors related to (a) the product's web interface, (b) the configuration of the print system, and (c) the titles of printed jobs, as demonstrated by an XSS attack that uses the kerberos parameter to the admin program, and leverages attribute injection and HTTP Parameter Pollution (HPP) issues.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1933-1
NVD severitymedium (attack range: remote)
Debian Bugs555666

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cups (PTS)wheezy, wheezy (security)1.5.3-5+deb7u6fixed
jessie1.7.5-11+deb8u2fixed
jessie (security)1.7.5-11+deb8u1fixed
stretch2.2.1-8fixed
buster, sid2.2.6-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cupssource(unstable)1.4.2-1low555666
cupssourcelenny1.3.8-1+lenny7mediumDSA-1933-1
cupsyssource(unstable)(unfixed)medium
cupsyssourceetch1.2.7-4+etch9mediumDSA-1933-1

Search for package or bug name: Reporting problems