CVE-2009-3050

NameCVE-2009-3050
DescriptionBuffer overflow in the set_page_size function in util.cxx in HTMLDOC 1.8.27 and earlier allows context-dependent attackers to execute arbitrary code via a long MEDIA SIZE comment. NOTE: it was later reported that there were additional vectors in htmllib.cxx and ps-pdf.cxx using an AFM font file with a long glyph name, but these vectors do not cross privilege boundaries.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs537637

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
htmldoc (PTS)buster1.9.3-1+deb10u4fixed
buster (security)1.9.3-1+deb10u2fixed
bullseye1.9.11-4+deb11u3fixed
bookworm1.9.16-1fixed
sid, trixie1.9.18-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
htmldocsource(unstable)1.8.27-4.1low537637

Notes

[etch] - htmldoc <no-dsa> (Minor issue)
[lenny] - htmldoc <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems