Information on source package htmldoc

Available versions

ReleaseVersion
buster1.9.3-1+deb10u4
buster (security)1.9.3-1+deb10u2
bullseye1.9.11-4+deb11u3
bookworm1.9.16-1
trixie1.9.18-1
sid1.9.18-1

Open unimportant issues

BugbusterbullseyebookwormtrixiesidDescription
CVE-2022-34035vulnerablevulnerablefixedfixedfixedHTMLDoc v1.9.12 and below was discovered to contain a heap overflow vi ...
CVE-2022-34033vulnerablevulnerablefixedfixedfixedHTMLDoc v1.9.15 was discovered to contain a heap overflow via (write_h ...
CVE-2022-0137vulnerablevulnerablefixedfixedfixedA heap buffer overflow in image_set_mask function of HTMLDOC before 1. ...
CVE-2021-34121vulnerablevulnerablefixedfixedfixedAn Out of Bounds flaw was discovered in htmodoc 1.9.12 in function par ...
CVE-2021-34119vulnerablevulnerablefixedfixedfixedA flaw was discovered in htmodoc 1.9.12 in function parse_paragraph in ...

Resolved issues

BugDescription
CVE-2022-28085A flaw was found in htmldoc commit 31f7804. A heap buffer overflow in ...
CVE-2022-27114There is a vulnerability in htmldoc 1.9.16. In image_load_jpeg functio ...
CVE-2022-24191In HTMLDOC 1.9.14, an infinite loop in the gif_read_lzw function can l ...
CVE-2022-0534A vulnerability was found in htmldoc version 1.9.15 where the stack ou ...
CVE-2021-43579A stack-based buffer overflow in image_load_bmp() in HTMLDOC <= 1.9.13 ...
CVE-2021-40985A stack-based buffer under-read in htmldoc before 1.9.12, allows attac ...
CVE-2021-26948Null pointer dereference in the htmldoc v1.9.11 and before may allow a ...
CVE-2021-26259A flaw was found in htmldoc in v1.9.12. Heap buffer overflow in render ...
CVE-2021-26252A flaw was found in htmldoc in v1.9.12. Heap buffer overflow in pspdf_ ...
CVE-2021-23206A flaw was found in htmldoc in v1.9.12 and prior. A stack buffer overf ...
CVE-2021-23191A security issue was found in htmldoc v1.9.12 and before. A NULL point ...
CVE-2021-23180A flaw was found in htmldoc in v1.9.12 and before. Null pointer derefe ...
CVE-2021-23165A flaw was found in htmldoc before v1.9.12. Heap buffer overflow in ps ...
CVE-2021-23158A flaw was found in htmldoc in v1.9.12. Double-free in function pspdf_ ...
CVE-2021-20308Integer overflow in the htmldoc 1.9.11 and before may allow attackers ...
CVE-2019-19630HTMLDOC 1.9.7 allows a stack-based buffer overflow in the hd_strlcpy() ...
CVE-2009-3050Buffer overflow in the set_page_size function in util.cxx in HTMLDOC 1 ...

Security announcements

DSA / DLADescription
DLA-3004-1htmldoc - security update
DLA-2928-1htmldoc - security update
DLA-2700-1htmldoc - security update
DSA-4928-1htmldoc - security update
DLA-2026-1htmldoc - security update

Search for package or bug name: Reporting problems