CVE-2009-3076

NameCVE-2009-3076
DescriptionMozilla Firefox before 3.0.14 does not properly implement certain dialogs associated with the (1) pkcs11.addmodule and (2) pkcs11.deletemodule operations, which makes it easier for remote attackers to trick a user into installing or removing an arbitrary PKCS11 module.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1885-1
NVD severityhigh (attack range: remote, user-initiated)
Debian/oldstablenot known to be vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xulrunner (PTS)wheezy, wheezy (security)24.8.1esr-2~deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xulrunnersource(unstable)1.9.0.14-1high
xulrunnersourceetch(unfixed)end-of-life
xulrunnersourcelenny1.9.0.14-0lenny1highDSA-1885-1

Notes

[etch] - xulrunner <end-of-life> (Etch Packages no longer covered by security support)

Search for package or bug name: Reporting problems