CVE-2009-3300

NameCVE-2009-3300
DescriptionMultiple cross-site scripting (XSS) vulnerabilities in the Identity Provider (IdP) 1.3.x before 1.3.4 and 2.x before 2.1.5, and the Service Provider 1.3.x before 1.3.5 and 2.x before 2.3, in Internet2 Middleware Initiative Shibboleth allow remote attackers to inject arbitrary web script or HTML via URLs that are encountered in redirections, and appear in automatically generated forms.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1947-1
NVD severitylow (attack range: remote)
Debian Bugs555608

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
opensaml2 (PTS)wheezy2.4.3-4+deb7u1fixed
wheezy (security)2.4.3-4+deb7u2fixed
jessie (security), jessie2.5.3-2+deb8u2fixed
stretch (security), stretch2.6.0-4+deb9u1fixed
buster, sid2.6.1-1fixed
shibboleth-sp2 (PTS)wheezy2.4.3+dfsg-5+deb7u1fixed
wheezy (security)2.4.3+dfsg-5+deb7u2fixed
jessie (security), jessie2.5.3+dfsg-2+deb8u1fixed
stretch (security), stretch2.6.0+dfsg1-4+deb9u1fixed
buster, sid2.6.1+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensaml2source(unstable)2.3-1medium
opensaml2sourcelenny2.0-2+lenny2lowDSA-1947-1
shibboleth-spsource(unstable)(unfixed)medium
shibboleth-spsourceetch1.3f.dfsg1-2+etch2lowDSA-1947-1
shibboleth-spsourcelenny1.3.1.dfsg1-3+lenny2lowDSA-1947-1
shibboleth-sp2source(unstable)2.3+dfsg-1medium555608
shibboleth-sp2sourcelenny2.0.dfsg1-4+lenny2lowDSA-1947-1

Notes

xmltooling also needs to be updated, changed in sid in 1.3.1-1

Search for package or bug name: Reporting problems