CVE-2009-3389

NameCVE-2009-3389
DescriptionInteger overflow in libtheora in Xiph.Org Theora before 1.1, as used in Mozilla Firefox 3.5 before 3.5.6 and SeaMonkey before 2.0.1, allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a video with large dimensions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2045-1
NVD severityhigh (attack range: remote)
Debian Bugs572950

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
iceweasel (PTS)wheezy, wheezy (security)38.8.0esr-1~deb7u1fixed
libtheora (PTS)wheezy1.1.1+dfsg.1-3.1fixed
jessie1.1.1+dfsg.1-6fixed
buster, sid, stretch1.1.1+dfsg.1-14fixed
xulrunner (PTS)wheezy, wheezy (security)24.8.1esr-2~deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceweaselsource(unstable)3.5.11-2high
iceweaselsourcelenny(not affected)
libtheorasource(unstable)1.1high572950
libtheorasourceetch(not affected)
libtheorasourcelenny1.0~beta3-1+lenny1highDSA-2045-1
xulrunnersource(unstable)1.9.1.6-1high
xulrunnersourceetch(unfixed)end-of-life
xulrunnersourcelenny(not affected)

Notes

[etch] - libtheora <not-affected> (vulnerable code not present)
[lenny] - iceweasel <not-affected> (Iceweasel in Lenny links against xulrunner)
[etch] - xulrunner <end-of-life> (Mozilla packages from oldstable no longer covered by security support)
[lenny] - xulrunner <not-affected> (Video playback capabilities were added in 3.5)

Search for package or bug name: Reporting problems