CVE-2009-3474

NameCVE-2009-3474
DescriptionOpenSAML 2.x before 2.2.1 and XMLTooling 1.x before 1.2.1, as used by Internet2 Shibboleth Service Provider 2.x before 2.2.1, do not follow the KeyDescriptor element's Use attribute, which allows remote attackers to use a certificate for both signing and encryption when it is designated for just one purpose, potentially weakening the intended security application of the certificate.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1895-1, DSA-1895-2, DSA-1896-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
opensaml (PTS)buster, sid3.0.0-2fixed
opensaml2 (PTS)jessie (security), jessie2.5.3-2+deb8u2fixed
stretch (security), stretch2.6.0-4+deb9u1fixed
shibboleth-sp (PTS)buster, sid3.0.2+dfsg1-2fixed
shibboleth-sp2 (PTS)jessie (security), jessie2.5.3+dfsg-2+deb8u1fixed
stretch (security), stretch2.6.0+dfsg1-4+deb9u1fixed
xmltooling (PTS)jessie (security), jessie1.5.3-2+deb8u3fixed
stretch (security), stretch1.6.0-4+deb9u1fixed
buster, sid3.0.2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensamlsource(unstable)3.0.0-2high
opensamlsourceetch1.1a-2+etch1highDSA-1896-1
opensamlsourcelenny1.1.1-2+lenny1high
opensaml2source(unstable)2.2.1-1high
opensaml2sourcelenny2.0-2+lenny1high
shibboleth-spsource(unstable)3.0.2+dfsg1-2high
shibboleth-spsourceetch1.3f.dfsg1-2+etch1highDSA-1896-1
shibboleth-spsourcelenny1.3.1.dfsg1-3+lenny1highDSA-1896-1
shibboleth-sp2source(unstable)2.2.1+dfsg-1high
shibboleth-sp2sourcelenny2.0.dfsg1-4+lenny1highDSA-1895-2
xmltoolingsource(unstable)1.2.2-1high
xmltoolingsourcelenny1.0-2+lenny1highDSA-1895-1

Search for package or bug name: Reporting problems