CVE-2009-3476

NameCVE-2009-3476
DescriptionBuffer overflow in OpenSAML before 1.1.3 as used in Internet2 Shibboleth Service Provider software 1.3.x before 1.3.4, and XMLTooling before 1.2.2 as used in Internet2 Shibboleth Service Provider software 2.x before 2.2.1, allows remote attackers to cause a denial of service and possibly execute arbitrary code via a malformed encoded URL.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1895-1, DSA-1895-2, DSA-1896-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
opensaml (PTS)buster, sid3.0.0-2fixed
opensaml2 (PTS)jessie (security), jessie2.5.3-2+deb8u2fixed
stretch (security), stretch2.6.0-4+deb9u1fixed
shibboleth-sp (PTS)buster3.0.3+dfsg1-1fixed
sid3.0.4+dfsg1-1fixed
shibboleth-sp2 (PTS)jessie (security), jessie2.5.3+dfsg-2+deb8u1fixed
stretch (security), stretch2.6.0+dfsg1-4+deb9u1fixed
xmltooling (PTS)jessie1.5.3-2+deb8u3fixed
jessie (security)1.5.3-2+deb8u4fixed
stretch1.6.0-4+deb9u1fixed
stretch (security)1.6.0-4+deb9u2fixed
buster, sid3.0.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensamlsource(unstable)3.0.0-2high
opensamlsourceetch1.1a-2+etch1highDSA-1896-1
opensamlsourcelenny1.1.1-2+lenny1highDSA-1896-1
opensaml2source(unstable)2.2.1-1high
opensaml2sourcelenny2.0-2+lenny1highDSA-1895-2
shibboleth-spsource(unstable)3.0.2+dfsg1-2high
shibboleth-spsourceetch1.3f.dfsg1-2+etch1highDSA-1896-1
shibboleth-spsourcelenny1.3.1.dfsg1-3+lenny1highDSA-1896-1
shibboleth-sp2source(unstable)2.2.1+dfsg-1high
shibboleth-sp2sourcelenny2.0.dfsg1-4+lenny1highDSA-1895-2
xmltoolingsource(unstable)1.2.2-1high
xmltoolingsourcelenny1.0-2+lenny1highDSA-1895-1

Search for package or bug name: Reporting problems