CVE-2009-3617

NameCVE-2009-3617
DescriptionFormat string vulnerability in the AbstractCommand::onAbort function in src/AbstractCommand.cc in aria2 before 1.6.2, when logging is enabled, allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via format string specifiers in a download URI. NOTE: some of these details are obtained from third party information.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
aria2 (PTS)stretch1.30.0-2fixed
stretch (security)1.30.0-2+deb9u1fixed
buster1.34.0-4fixed
bullseye1.35.0-3fixed
bookworm, sid1.36.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
aria2sourceetch(not affected)
aria2sourcelenny(not affected)
aria2source(unstable)1.6.2-1low

Notes

[lenny] - aria2 <not-affected> (Vulnerable code not present)
[etch] - aria2 <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems