CVE-2009-3641

NameCVE-2009-3641
DescriptionSnort before 2.8.5.1, when the -v option is enabled, allows remote attackers to cause a denial of service (application crash) via a crafted IPv6 packet that uses the (1) TCP or (2) ICMP protocol.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs553584

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
snort (PTS)buster, bullseye, stretch, sid2.9.7.0-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
snortsource(unstable)2.8.5.2-1unimportant553584

Notes

current debian packages are not compiled with support for ipv6

Search for package or bug name: Reporting problems