CVE-2009-3996

NameCVE-2009-3996
DescriptionHeap-based buffer overflow in IN_MOD.DLL (aka the Module Decoder Plug-in) in Winamp before 5.57, and libmikmod 3.1.12, might allow remote attackers to execute arbitrary code via an Ultratracker file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2071-1
NVD severityhigh (attack range: remote)
Debian Bugs575742

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libmikmod (PTS)wheezy3.1.12-5fixed
jessie3.3.7-1fixed
stretch3.3.10-1fixed
buster, sid3.3.11.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libmikmodsource(unstable)3.1.11-6.2high575742
libmikmodsourcelenny3.1.11-6+lenny1highDSA-2071-1
pysol-sound-serversource(unstable)(unfixed)unimportant

Notes

pysol-sound-server embeds a mikmod copy, but only reads to local files

Search for package or bug name: Reporting problems