CVE-2009-4033

NameCVE-2009-4033
DescriptionA certain Red Hat patch for acpid 1.0.4 effectively triggers a call to the open function with insufficient arguments, which might allow local users to leverage weak permissions on /var/log/acpid, and obtain sensitive information by reading this file, cause a denial of service by overwriting this file, or gain privileges by executing this file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
acpid (PTS)stretch1:2.0.28-1fixed
buster1:2.0.31-1fixed
bullseye, sid1:2.0.32-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
acpidsource(unstable)(not affected)

Notes

- acpid <not-affected> (problem in redhat-specific patch; debian uses sensible permissions 0664)
https://bugzilla.redhat.com/show_bug.cgi?id=515062

Search for package or bug name: Reporting problems