CVE-2010-0160

NameCVE-2010-0160
DescriptionThe Web Worker functionality in Mozilla Firefox 3.0.x before 3.0.18 and 3.5.x before 3.5.8, and SeaMonkey before 2.0.3, does not properly handle array data types for posted messages, which allows remote attackers to cause a denial of service (heap memory corruption and application crash) or possibly execute arbitrary code via unspecified vectors.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
NVD severityhigh (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
iceape (PTS)squeeze (security)2.0.11-17fixed
iceweasel (PTS)squeeze (security), squeeze3.5.16-20fixed
wheezy31.3.0esr-1~deb7u1fixed
wheezy (security)31.5.3esr-1~deb7u1fixed
jessie, sid31.5.3esr-1fixed
xulrunner (PTS)wheezy, wheezy (security)24.8.1esr-2~deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceapesource(unstable)2.0.3-1high
iceapesourceetch(not affected)
iceapesourcelenny(not affected)
iceweaselsource(unstable)3.5.11-2high
iceweaselsourcelenny(not affected)
xulrunnersource(unstable)1.9.1.8-1high
xulrunnersourceetch(not affected)
xulrunnersourcelenny(not affected)

Notes

[etch] - xulrunner <not-affected> (web workers introduced in gecko 1.9.1)
[lenny] - xulrunner <not-affected> (web workers introduced in gecko 1.9.1)
[lenny] - iceweasel <not-affected> (Iceweasel in Lenny links against xulrunner)
[etch] - iceape <not-affected> (web workers introduced in gecko 1.9.1)
[lenny] - iceape <not-affected> (web workers introduced in gecko 1.9.1)

Search for package or bug name: Reporting problems