CVE-2010-1205

NameCVE-2010-1205
DescriptionBuffer overflow in pngpread.c in libpng before 1.2.44 and 1.4.x before 1.4.3, as used in progressive applications, might allow remote attackers to execute arbitrary code via a PNG image that triggers an additional data row.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2072-1, DSA-2075-1
NVD severityhigh (attack range: remote)
Debian Bugs587670
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icedove (PTS)squeeze (security), squeeze3.0.11-1+squeeze15fixed
wheezy31.3.0-1~deb7u1fixed
wheezy (security)31.6.0-1~deb7u1fixed
sid, jessie31.6.0-1fixed
libpng (PTS)squeeze (security), squeeze1.2.44-1+squeeze4fixed
wheezy1.2.49-1fixed
sid, jessie1.2.50-2fixed
tuxonice-userui (PTS)wheezy1.1-1fixed
sid, jessie1.1+dfsg1.gc3bdd83-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
icedovesource(unstable)3.0.6-1high
icedovesourcelenny(unfixed)end-of-life
libpngsource(unstable)1.2.44-1high587670
libpngsourcelenny1.2.27-2+lenny4highDSA-2072-1
tuxonice-useruisource(unstable)1.0-1unimportant
xulrunnersourcelenny1.9.0.19-3highDSA-2075-1

Notes

tuxonice-userui 1.0-1 was binNMUed

Search for package or bug name: Reporting problems