CVE-2010-1214

NameCVE-2010-1214
DescriptionInteger overflow in Mozilla Firefox 3.5.x before 3.5.11 and 3.6.x before 3.6.7, and SeaMonkey before 2.0.6, allows remote attackers to execute arbitrary code via plugin content with many parameter elements.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2075-1
NVD severityhigh (attack range: remote, user-initiated)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
iceape (PTS)squeeze (security)2.0.11-17fixed
iceweasel (PTS)squeeze, squeeze (security)3.5.16-20fixed
wheezy31.3.0esr-1~deb7u1fixed
wheezy (security)38.2.1esr-1~deb7u1fixed
jessie31.6.0esr-1fixed
jessie (security)38.2.1esr-1~deb8u1fixed
stretch38.2.0esr-1~stretchfixed
sid38.2.1esr-1fixed
xulrunner (PTS)wheezy (security), wheezy24.8.1esr-2~deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceapesource(unstable)2.0.6-1high
iceapesourcelenny(not affected)
iceweaselsource(unstable)3.5.11-2high
iceweaselsourcelenny(not affected)
xulrunnersource(unstable)1.9.1.11-1high
xulrunnersourcelenny1.9.0.19-3highDSA-2075-1

Notes

[lenny] - iceweasel <not-affected> (Iceweasel in Lenny links against xulrunner)
[lenny] - iceape <not-affected> (Only a stub package)

Search for package or bug name: Reporting problems