CVE-2010-2155

NameCVE-2010-2155
DescriptionMultiple cross-site scripting (XSS) vulnerabilities in zc/publisher/html.rb in ZoneCheck 2.1.0 allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) xmlnode.value, (2) zc-error text, (3) $zc_version, (4) domainname in a zc-title row, different vulnerabilities than CVE-2009-4882.
SourceCVE (at NVD; LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2056-1
NVD severitymedium (attack range: remote)
Debian Bugs583290

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
zonecheck (PTS)wheezy3.0.3-2fixed
stretch, sid, jessie3.0.5-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
zonechecksource(unstable)2.1.1-1medium583290
zonechecksourcelenny2.0.4-13lenny1mediumDSA-2056-1

Search for package or bug name: Reporting problems