CVE-2010-2761

NameCVE-2010-2761
DescriptionThe multipart_init function in (1) CGI.pm before 3.50 and (2) Simple.pm in CGI::Simple 1.112 and earlier uses a hardcoded value of the MIME boundary string in multipart/x-mixed-replace content, which allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via crafted input that contains this value, a different vulnerability than CVE-2010-3172.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs606370, 606379, 606995

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libcgi-pm-perl (PTS)jessie4.09-1fixed
stretch4.35-1fixed
buster4.40-1fixed
bullseye, sid4.46-1fixed
libcgi-simple-perl (PTS)jessie1.115-1fixed
bullseye, sid, buster, stretch1.115-2fixed
perl (PTS)jessie5.20.2-3+deb8u11fixed
jessie (security)5.20.2-3+deb8u12fixed
stretch5.24.1-3+deb9u6fixed
stretch (security)5.24.1-3+deb9u5fixed
buster5.28.1-6fixed
bullseye, sid5.30.0-9fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libcgi-pm-perlsource(unstable)3.50-1606370
libcgi-pm-perlsourcelenny3.38-2lenny2
libcgi-pm-perlsourcesqueeze3.49-1squeeze1
libcgi-simple-perlsource(unstable)1.111-2606379
libcgi-simple-perlsourcelenny1.105-1lenny1
perlsource(unstable)5.10.1-17606995
perlsourcelenny5.10.0-19lenny3606995

Search for package or bug name: Reporting problems