CVE-2010-2945

NameCVE-2010-2945
DescriptionThe default configuration of SLiM before 1.3.2 places ./ (dot slash) at the beginning of the default_path option, which might allow local users to gain privileges via a Trojan horse program in the current working directory, related to slim.conf and cfg.cpp.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs594414

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
slim (PTS)buster, stretch1.3.6-5.1fixed
bullseye1.3.6-5.2fixed
bookworm, sid1.3.6-5.3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
slimsourcelenny1.3.0-1+lenny3
slimsource(unstable)1.3.1-7low594414

Search for package or bug name: Reporting problems