CVE-2010-3183

NameCVE-2010-3183
DescriptionThe LookupGetterOrSetter function in js3250.dll in Mozilla Firefox before 3.5.14 and 3.6.x before 3.6.11, Thunderbird before 3.0.9 and 3.1.x before 3.1.5, and SeaMonkey before 2.0.9 does not properly support window.__lookupGetter__ function calls that lack arguments, which allows remote attackers to execute arbitrary code or cause a denial of service (incorrect pointer dereference and application crash) via vectors involving a "dangling pointer" and the JS_ValueToId function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2124-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icedove (PTS)jessie (security), jessie1:52.3.0-4~deb8u2fixed
stretch (security)1:52.3.0-4~deb9u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceapesource(unstable)2.0.9-1high
iceapesourcelenny(not affected)
icedovesource(unstable)3.0.9-1high
icedovesourcelenny(unfixed)end-of-life
iceweaselsource(unstable)3.5.14-1high
iceweaselsourcelenny(not affected)
xulrunnersource(unstable)(unfixed)unimportant
xulrunnersourcelenny1.9.0.19-6highDSA-2124-1

Notes

[lenny] - iceweasel <not-affected> (Lenny's iceweasel uses Xulrunner from the xulrunner source pkg)
[lenny] - iceape <not-affected> (Only a stub package)
[lenny] - xulrunner <not-affected> (bug in optimization added later)
xulrunner in wheezy is not covered by security support

Search for package or bug name: Reporting problems