CVE-2010-3380

NameCVE-2010-3380
DescriptionThe (1) init.d/slurm and (2) init.d/slurmdbd scripts in SLURM before 2.1.14 place the . (dot) directory in the LD_LIBRARY_PATH, which allows local users to gain privileges via a Trojan horse shared library in the current working directory.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs602340

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
slurm-llnl (PTS)jessie14.03.9-5+deb8u2fixed
jessie (security)14.03.9-5+deb8u4fixed
stretch16.05.9-1+deb9u4fixed
stretch (security)16.05.9-1+deb9u2fixed
buster18.08.5.2-1fixed
buster (security)18.08.5.2-1+deb10u1fixed
bullseye19.05.3.2-2fixed
sid19.05.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
slurm-llnlsource(unstable)2.1.15-2602340
slurm-llnlsourcesqueeze2.1.11-1squeeze1602340
slurm-llnlsourcewheezy2.1.11-1squeeze1602340

Notes

[lenny] - slurm-llnl <no-dsa> (Minor issue)
Debian package ships its own, also vulnerable, init script. NOT fixed in 2.1.14-1

Search for package or bug name: Reporting problems