CVE-2010-3441

NameCVE-2010-3441
DescriptionMultiple buffer overflows in abcm2ps before 5.9.12 might allow remote attackers to execute arbitrary code via (1) a crafted input file, related to the PUT0 and PUT1 output macros; (2) a crafted input file, related to the trim_title function; and possibly (3) a long -O option on a command line.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs577014

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
abcm2ps (PTS)stretch7.8.9-1fixed
buster8.14.2-0.2fixed
bookworm, sid, bullseye8.14.11-0.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
abcm2pssource(unstable)5.9.13-0.1low577014

Notes

[lenny] - abcm2ps <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems