CVE-2010-3900

NameCVE-2010-3900
DescriptionMidori before 0.2.5, when WebKitGTK+ before 1.1.14 or LibSoup before 2.29.91 is used, does not verify X.509 certificates, which allows man-in-the-middle attackers to spoof arbitrary https web sites via a crafted server certificate, a related issue to CVE-2010-3312.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs607497

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
midori (PTS)stretch0.5.11-ds1-4fixed
buster7.0-2fixed
bullseye, sid7.0-2.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
midorisource(unstable)0.2.7-1.1unimportant607497

Notes

Current Midori SSL support is very limited
Midori should not be used if SSL support is important to you

Search for package or bug name: Reporting problems