CVE-2010-3906

NameCVE-2010-3906
DescriptionCross-site scripting (XSS) vulnerability in Gitweb 1.7.3.3 and earlier allows remote attackers to inject arbitrary web script or HTML via the (1) f and (2) fp parameters.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
git (PTS)stretch (security), stretch1:2.11.0-3+deb9u7fixed
buster, buster (security)1:2.20.1-2+deb10u3fixed
bullseye1:2.30.2-1fixed
bookworm, sid1:2.33.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gitsource(unstable)1:1.7.2.3-2.2
git-coresourcelenny1.5.6.5-3+lenny3.3
git-coresource(unstable)(unfixed)

Search for package or bug name: Reporting problems