Information on source package git

Available versions

ReleaseVersion
stretch1:2.11.0-3+deb9u7
buster1:2.20.1-2+deb10u3
bullseye1:2.30.2-1
bookworm1:2.33.0-1
sid1:2.33.0-1

Open issues

BugstretchbusterbullseyebookwormsidDescription
CVE-2021-40330vulnerable (no DSA)vulnerable (no DSA)fixedfixedfixedgit_connect_git in connect.c in Git before 2.30.1 allows a repository ...
CVE-2021-21300vulnerable (no DSA)vulnerable (no DSA)fixedfixedfixedGit is an open-source distributed revision control system. In affected ...

Open unimportant issues

BugstretchbusterbullseyebookwormsidDescription
CVE-2019-1354vulnerablefixedfixedfixedfixedA remote code execution vulnerability exists when Git for Visual Studi ...
CVE-2019-1351vulnerablefixedfixedfixedfixedA tampering vulnerability exists when Git for Visual Studio improperly ...
CVE-2019-1350vulnerablefixedfixedfixedfixedA remote code execution vulnerability exists when Git for Visual Studi ...
CVE-2018-1000021vulnerablevulnerablevulnerablevulnerablevulnerableGIT version 2.15.1 and earlier contains a Input Validation Error vulne ...
CVE-2017-15298vulnerablefixedfixedfixedfixedGit through 2.14.2 mishandles layers of tree objects, which allows rem ...

Resolved issues

BugDescription
CVE-2020-11008Affected versions of Git have a vulnerability whereby Git can be trick ...
CVE-2020-5260Affected versions of Git have a vulnerability whereby Git can be trick ...
CVE-2019-19604Arbitrary command execution is possible in Git before 2.20.2, 2.21.x b ...
CVE-2019-1387An issue was found in Git before v2.24.1, v2.23.1, v2.22.2, v2.21.1, v ...
CVE-2019-1353An issue was found in Git before v2.24.1, v2.23.1, v2.22.2, v2.21.1, v ...
CVE-2019-1352A remote code execution vulnerability exists when Git for Visual Studi ...
CVE-2019-1349A remote code execution vulnerability exists when Git for Visual Studi ...
CVE-2019-1348An issue was found in Git before v2.24.1, v2.23.1, v2.22.2, v2.21.1, v ...
CVE-2018-19486Git before 2.19.2 on Linux and UNIX executes commands from the current ...
CVE-2018-17456Git before 2.14.5, 2.15.x before 2.15.3, 2.16.x before 2.16.5, 2.17.x ...
CVE-2018-11235In Git before 2.13.7, 2.14.x before 2.14.4, 2.15.x before 2.15.2, 2.16 ...
CVE-2018-11233In Git before 2.13.7, 2.14.x before 2.14.4, 2.15.x before 2.15.2, 2.16 ...
CVE-2017-1000117A malicious third-party can give a crafted "ssh://..." URL to an unsus ...
CVE-2017-14867Git before 2.10.5, 2.11.x before 2.11.4, 2.12.x before 2.12.5, 2.13.x ...
CVE-2017-8386git-shell in git before 2.4.12, 2.5.x before 2.5.6, 2.6.x before 2.6.7 ...
CVE-2016-2324Integer overflow in Git before 2.7.4 allows remote attackers to execut ...
CVE-2016-2315revision.c in git before 2.7.4 uses an incorrect integer data type, wh ...
CVE-2015-7545The (1) git-remote-ext and (2) unspecified other remote helper program ...
CVE-2014-9938contrib/completion/git-prompt.sh in Git before 1.9.3 does not sanitize ...
CVE-2014-9390Git before 1.8.5.6, 1.9.x before 1.9.5, 2.0.x before 2.0.5, 2.1.x befo ...
CVE-2013-0308The imap-send command in GIT before 1.8.1.4 does not verify that the s ...
CVE-2010-3906Cross-site scripting (XSS) vulnerability in Gitweb 1.7.3.3 and earlier ...

Security announcements

DSA / DLADescription
DLA-2182-1git - security update
DSA-4659-1git - security update
DLA-2177-1git - security update
DSA-4657-1git - security update
DLA-2059-1git - security update
DSA-4581-1git - security update
DSA-4311-1git - security update
DLA-1533-1git - security update
DSA-4212-1git - security update
DLA-1120-1git - security update
DSA-3984-1git - security update
DLA-1068-1git - security update
DSA-3934-1git - security update
DSA-3848-1git - security update
DLA-938-1git - security update
DSA-3521-1git - security update
DSA-3435-1git - security update

Search for package or bug name: Reporting problems