CVE-2010-4171

NameCVE-2010-4171
DescriptionThe staprun runtime tool in SystemTap 1.3 does not verify that a module to unload was previously loaded by SystemTap, which allows local users to cause a denial of service (unloading of arbitrary kernel modules).
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2348-1
NVD severitylow (attack range: local)
Debian Bugs603946
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
systemtap (PTS)squeeze (security), squeeze1.2-5+squeeze1fixed
wheezy1.7-1+deb7u1fixed
jessie, sid2.6-0.2fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
systemtapsource(unstable)1.2-3low603946
systemtapsourcesqueeze1.2-5+squeeze1lowDSA-2348-1

Search for package or bug name: Reporting problems