CVE-2010-4411

NameCVE-2010-4411
DescriptionUnspecified vulnerability in CGI.pm 3.50 and earlier allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via unknown vectors. NOTE: this issue exists because of an incomplete fix for CVE-2010-2761.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs606370, 606379, 606995

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libcgi-pm-perl (PTS)stretch4.35-1fixed
buster4.40-1fixed
bullseye4.51-1fixed
bookworm, sid4.53-1fixed
libcgi-simple-perl (PTS)bookworm, sid, buster, bullseye, stretch1.115-2fixed
perl (PTS)stretch5.24.1-3+deb9u7fixed
stretch (security)5.24.1-3+deb9u5fixed
buster5.28.1-6+deb10u1fixed
bullseye5.32.1-4+deb11u2fixed
bullseye (security)5.32.1-4+deb11u1fixed
bookworm, sid5.32.1-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libcgi-pm-perlsourcelenny3.38-2lenny2
libcgi-pm-perlsourcesqueeze3.49-1squeeze1
libcgi-pm-perlsource(unstable)3.51-1606370
libcgi-simple-perlsourcelenny1.105-1lenny1
libcgi-simple-perlsource(unstable)1.111-2606379
perlsourcelenny5.10.0-19lenny3
perlsource(unstable)5.10.1-17606995

Search for package or bug name: Reporting problems