CVE-2011-0051

NameCVE-2011-0051
DescriptionMozilla Firefox before 3.5.17 and 3.6.x before 3.6.14, and SeaMonkey before 2.0.12, does not properly handle certain recursive eval calls, which makes it easier for remote attackers to force a user to respond positively to a dialog question, as demonstrated by a question about granting privileges.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2180-1, DSA-2186-1, DSA-2187-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icedove (PTS)wheezy38.7.0-1~deb7u1fixed
wheezy (security)1:52.3.0-4~deb7u2fixed
jessie1:45.8.0-3~deb8u1fixed
jessie (security)1:52.3.0-4~deb8u2fixed
stretch (security), stretch1:52.3.0-4~deb9u1fixed
buster, sid1:52.3.0-4fixed
iceweasel (PTS)wheezy, wheezy (security)38.8.0esr-1~deb7u1fixed
jessie (security)38.8.0esr-1~deb8u1fixed
xulrunner (PTS)wheezy, wheezy (security)24.8.1esr-2~deb7u1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceapesource(unstable)2.0.12-1medium
iceapesourcelenny(not affected)
iceapesourcesqueeze2.0.11-3mediumDSA-2180-1
icedovesource(unstable)3.0.11-2medium
icedovesourcelenny(unfixed)end-of-life
icedovesourcesqueeze3.0.11-1+squeeze1mediumDSA-2187-1
iceweaselsource(unstable)3.5.17-1medium
iceweaselsourcelenny(not affected)
iceweaselsourcesqueeze3.5.16-5mediumDSA-2186-1
xulrunnersource(unstable)(unfixed)unimportant
xulrunnersourcelenny1.9.0.19-8medium

Notes

[lenny] - iceweasel <not-affected> (Lenny's iceweasel uses Xulrunner from the xulrunner source pkg)
[lenny] - iceape <not-affected> (Only a stub package)
xulrunner in wheezy is not covered by security support

Search for package or bug name: Reporting problems