CVE-2011-0065

NameCVE-2011-0065
DescriptionUse-after-free vulnerability in Mozilla Firefox before 3.5.19 and 3.6.x before 3.6.17, and SeaMonkey before 2.0.14, allows remote attackers to execute arbitrary code via vectors related to OBJECT's mChannel.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2227-1, DSA-2228-1, DSA-2235-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icedove (PTS)wheezy38.7.0-1~deb7u1fixed
wheezy (security)1:45.4.0-1~deb7u1fixed
jessie1:45.2.0-1~deb8u1fixed
jessie (security)1:45.4.0-1~deb8u1fixed
stretch1:45.4.0-1fixed
sid1:45.5.1-1fixed
iceweasel (PTS)wheezy (security), wheezy38.8.0esr-1~deb7u1fixed
jessie (security)38.8.0esr-1~deb8u1fixed
xulrunner (PTS)wheezy (security), wheezy24.8.1esr-2~deb7u1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceapesource(unstable)2.0.14-1high
iceapesourcelenny(not affected)
iceapesourcesqueeze2.0.11-5highDSA-2227-1
icedovesource(unstable)3.1.15-1+b1high
icedovesourcesqueeze3.0.11-1+squeeze2highDSA-2235-1
iceweaselsource(unstable)3.5.19-1high
iceweaselsourcelenny(not affected)
iceweaselsourcesqueeze3.5.16-7highDSA-2228-1
xulrunnersource(unstable)(unfixed)unimportant

Notes

[lenny] - iceweasel <not-affected> (Lenny's iceweasel uses Xulrunner from the xulrunner source pkg)
[lenny] - iceape <not-affected> (Only a stub package)
xulrunner in wheezy is not covered by security support

Search for package or bug name: Reporting problems