CVE-2011-0067

NameCVE-2011-0067
DescriptionMozilla Firefox before 3.5.19 and 3.6.x before 3.6.17, and SeaMonkey before 2.0.14, does not properly implement autocompletion for forms, which allows remote attackers to read form history entries via a Java applet that spoofs interaction with the autocomplete controls.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2227-1, DSA-2228-1, DSA-2235-1
NVD severitymedium (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablepackage xulrunner is vulnerable; however, the security impact is unimportant.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
iceape (PTS)squeeze (security)2.0.11-17fixed
icedove (PTS)squeeze (security), squeeze3.0.11-1+squeeze15fixed
iceweasel (PTS)squeeze (security), squeeze3.5.16-20fixed
wheezy31.3.0esr-1~deb7u1fixed
wheezy (security)31.6.0esr-1~deb7u1fixed
jessie, sid31.6.0esr-1fixed
xulrunner (PTS)wheezy, wheezy (security)24.8.1esr-2~deb7u1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceapesource(unstable)2.0.14-1medium
iceapesourcelenny(not affected)
iceapesourcesqueeze2.0.11-5mediumDSA-2227-1
icedovesourcesqueeze3.0.11-1+squeeze2mediumDSA-2235-1
iceweaselsource(unstable)3.5.19-1medium
iceweaselsourcelenny(not affected)
iceweaselsourcesqueeze3.5.16-7mediumDSA-2228-1
xulrunnersource(unstable)(unfixed)unimportant

Notes

[lenny] - iceweasel <not-affected> (Lenny's iceweasel uses Xulrunner from the xulrunner source pkg)
[lenny] - iceape <not-affected> (Only a stub package)
xulrunner in wheezy is not covered by security support

Search for package or bug name: Reporting problems