CVE-2011-0530

NameCVE-2011-0530
DescriptionBuffer overflow in the mainloop function in nbd-server.c in the server in Network Block Device (nbd) before 2.9.20 might allow remote attackers to execute arbitrary code via a long request. NOTE: this issue exists because of a CVE-2005-3534 regression.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2183-1
NVD severityhigh (attack range: remote)
Debian Bugs611187

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nbd (PTS)wheezy, wheezy (security)1:3.2-4~deb7u5fixed
jessie1:3.8-4+deb8u3fixed
jessie (security)1:3.8-4+deb8u1fixed
stretch1:3.15.2-3fixed
buster, sid1:3.16.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nbdsource(unstable)1:2.9.16-8high611187
nbdsourceetch(not affected)
nbdsourcelenny1:2.9.11-3lenny1highDSA-2183-1

Notes

[etch] - nbd <not-affected> (reintroduced in 2.9.0)

Search for package or bug name: Reporting problems