CVE-2011-0905

NameCVE-2011-0905
DescriptionThe rfbSendFramebufferUpdate function in server/libvncserver/rfbserver.c in vino-server in Vino 2.x before 2.28.3, 2.32.x before 2.32.2, 3.0.x before 3.0.2, and 3.1.x before 3.1.1, when tight encoding is used, allows remote authenticated users to cause a denial of service (daemon crash) via crafted dimensions in a framebuffer update request that triggers an out-of-bounds read operation.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2238-1
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvncserver (PTS)stretch0.9.11+dfsg-1.3~deb9u4fixed
stretch (security)0.9.11+dfsg-1.3~deb9u6fixed
buster0.9.11+dfsg-1.3+deb10u4fixed
bullseye0.9.13+dfsg-2fixed
bookworm, sid0.9.13+dfsg-3fixed
vino (PTS)stretch3.22.0-1fixed
buster3.22.0-5fixed
bookworm, sid, bullseye3.22.0-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kdenetworksource(unstable)4:4.0
libvncserversource(unstable)(not affected)
vinosourcesqueeze2.28.2-2+squeeze1DSA-2238-1
vinosource(unstable)2.28.2-3

Notes

- libvncserver <not-affected> (Performs sufficient range validation, but was initially reported as affected)
Only affects the krfb from KDE 3.5

Search for package or bug name: Reporting problems