Information on source package libvncserver

Available versions

ReleaseVersion
jessie (security)0.9.9+dfsg2-6.1+deb8u3
stretch0.9.11+dfsg-1
stretch (security)0.9.11+dfsg-1+deb9u1
buster0.9.11+dfsg-1.1
sid0.9.11+dfsg-1.1

Resolved issues

BugDescription
TEMP-0000000-70147BMemory corruption
CVE-2018-7225An issue was discovered in LibVNCServer through 0.9.11. ...
CVE-2016-9942Heap-based buffer overflow in ultra.c in LibVNCClient in LibVNCServer ...
CVE-2016-9941Heap-based buffer overflow in rfbproto.c in LibVNCClient in ...
CVE-2014-6055Multiple stack-based buffer overflows in the File Transfer feature in ...
CVE-2014-6054The rfbProcessClientNormalMessage function in libvncserver/rfbserver.c ...
CVE-2014-6053The rfbProcessClientNormalMessage function in libvncserver/rfbserver.c ...
CVE-2014-6052The HandleRFBServerMessage function in libvncclient/rfbproto.c in ...
CVE-2014-6051Integer overflow in the MallocFrameBuffer function in vncviewer.c in ...
CVE-2011-0905The rfbSendFramebufferUpdate function in ...
CVE-2011-0904The rfbSendFramebufferUpdate function in ...
CVE-2006-2450auth.c in LibVNCServer 0.7.1 allows remote attackers to bypass ...

Security announcements

DSA / DLADescription
DSA-4221-1libvncserver - security update
DSA-4221-1libvncserver - security update
DLA-1332-1libvncserver - security update
DSA-3753-1libvncserver - security update
DLA-777-1libvncserver - security update
DLA-380-1libvncserver - security update
DLA-197-1libvncserver - security update
DSA-3081-1libvncserver - security update

Search for package or bug name: Reporting problems