CVE-2011-1156

NameCVE-2011-1156
Descriptionfeedparser.py in Universal Feed Parser (aka feedparser or python-feedparser) before 5.0.1 allows remote attackers to cause a denial of service (application crash) via a malformed DOCTYPE declaration.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs617998, 684246

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
feedparser (PTS)buster5.2.1-1fixed
bullseye5.2.1-3fixed
bookworm, sid6.0.8-2fixed
planet-venus (PTS)buster0~git9de2109-4.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
feedparsersource(unstable)5.0.1-1low617998
planet-venussource(unstable)0~git9de2109-2low684246

Notes

[squeeze] - feedparser <no-dsa> (Minor issue)
[lenny] - feedparser <no-dsa> (Minor issue)
[wheezy] - planet-venus <no-dsa> (Minor issue)
[squeeze] - planet-venus <no-dsa> (Minor issue)
[lenny] - planet-venus <no-dsa> (Minor issue)
http://web.archive.org/web/20130326201801/http://code.google.com/p/feedparser/issues/detail?id=91

Search for package or bug name: Reporting problems