CVE-2011-1158

NameCVE-2011-1158
DescriptionCross-site scripting (XSS) vulnerability in feedparser.py in Universal Feed Parser (aka feedparser or python-feedparser) 5.x before 5.0.1 allows remote attackers to inject arbitrary web script or HTML via an unexpected URI scheme, as demonstrated by a javascript: URI.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs617998, 684246

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
feedparser (PTS)buster5.2.1-1fixed
bullseye5.2.1-3fixed
bookworm, sid6.0.8-2fixed
planet-venus (PTS)buster0~git9de2109-4.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
feedparsersource(unstable)5.0.1-1low617998
planet-venussource(unstable)0~git9de2109-2low684246

Notes

[squeeze] - feedparser <no-dsa> (Minor issue)
[lenny] - feedparser <no-dsa> (Minor issue)
[wheezy] - planet-venus <no-dsa> (Minor issue)
[squeeze] - planet-venus <no-dsa> (Minor issue)
[lenny] - planet-venus <no-dsa> (Minor issue)
http://web.archive.org/web/20120304003020/https://code.google.com/p/feedparser/issues/detail?id=255

Search for package or bug name: Reporting problems