CVE-2011-2374

NameCVE-2011-2374
DescriptionMultiple unspecified vulnerabilities in the browser engine in Mozilla Firefox before 3.6.18 and 4.x through 4.0.1, and Thunderbird before 3.1.11, allow remote attackers to cause a denial of service (memory corruption and application crash) or possibly execute arbitrary code via unknown vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2268-1, DSA-2269-1, DSA-2273-3
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icedove (PTS)wheezy38.7.0-1~deb7u1fixed
wheezy (security)1:45.2.0-2~deb7u1fixed
jessie, jessie (security)1:45.2.0-1~deb8u1fixed
stretch1:45.2.0-4fixed
sid1:45.3.0-1fixed
iceweasel (PTS)wheezy, wheezy (security)38.8.0esr-1~deb7u1fixed
jessie (security)38.8.0esr-1~deb8u1fixed
xulrunner (PTS)wheezy, wheezy (security)24.8.1esr-2~deb7u1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceapesource(unstable)2.0.14-3high
iceapesourcelenny(not affected)
iceapesourcesqueeze2.0.11-6highDSA-2269-1
icedovesource(unstable)3.1.11-1high
icedovesourcelenny(unfixed)end-of-life
icedovesourcesqueeze3.0.11-1+squeeze3highDSA-2273-3
iceweaselsource(unstable)3.5.19-3high
iceweaselsourcelenny(not affected)
iceweaselsourcesqueeze3.5.16-8highDSA-2268-1
xulrunnersource(unstable)(unfixed)unimportant
xulrunnersourcelenny1.9.0.19-12high

Notes

[lenny] - iceweasel <not-affected> (Lenny's iceweasel uses Xulrunner from the xulrunner source pkg)
[lenny] - iceape <not-affected> (Only a stub package)
xulrunner in wheezy is not covered by security support

Search for package or bug name: Reporting problems