CVE-2011-2503

NameCVE-2011-2503
DescriptionThe insert_module function in runtime/staprun/staprun_funcs.c in the systemtap runtime tool (staprun) in SystemTap before 1.6 does not properly validate a module when loading it, which allows local users to gain privileges via a race condition between the signature validation and the module initialization.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2348-1
NVD severitylow (attack range: local)
Debian Bugs635542
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
systemtap (PTS)squeeze (security), squeeze1.2-5+squeeze1fixed
wheezy1.7-1+deb7u1fixed
jessie, sid2.6-0.2fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
systemtapsource(unstable)1.6-1low635542
systemtapsourcelenny(not affected)
systemtapsourcesqueeze1.2-5+squeeze1lowDSA-2348-1

Notes

[lenny] - systemtap <not-affected> (Signed modules not yet supported)

Search for package or bug name: Reporting problems