CVE-2011-2685

NameCVE-2011-2685
DescriptionStack-based buffer overflow in the Lotus Word Pro import filter in LibreOffice before 3.3.3 allows remote attackers to execute arbitrary code via a crafted .lwp file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-2275-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libreoffice (PTS)buster1:6.1.5-3+deb10u7fixed
buster (security)1:6.1.5-3+deb10u12fixed
bullseye1:7.0.4-4+deb11u8fixed
bullseye (security)1:7.0.4-4+deb11u9fixed
bookworm4:7.4.7-1+deb12u1fixed
bookworm (security)4:7.4.7-1+deb12u2fixed
sid, trixie4:24.2.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libreofficesource(unstable)1:3.3.3-1
openoffice.orgsourcelenny(not affected)
openoffice.orgsourcesqueeze1:3.2.1-11+squeeze3DSA-2275-1
openoffice.orgsource(unstable)1:3.3.0-1

Notes

[lenny] - openoffice.org <not-affected> (Vulnerable code not present)
Since 3.3.0 openoffice.org is a transitional source package to migrate to libreoffice

Search for package or bug name: Reporting problems