CVE-2011-2713

NameCVE-2011-2713
Descriptionoowriter in OpenOffice.org 3.3.0 and LibreOffice before 3.4.3 allows user-assisted remote attackers to cause a denial of service (crash) via a crafted DOC file that triggers an out-of-bounds read in the DOC sprm parser.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2315-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libreoffice (PTS)stretch (security), stretch1:5.2.7-1+deb9u11fixed
buster1:6.1.5-3+deb10u7fixed
buster (security)1:6.1.5-3+deb10u4fixed
bullseye1:7.0.4-4fixed
bullseye (security)1:7.0.4-4+deb11u1fixed
bookworm, sid1:7.2.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libreofficesource(unstable)1:3.4.3-1
openoffice.orgsourcelenny1:2.4.1+dfsg-1+lenny12DSA-2315-1
openoffice.orgsourcesqueeze1:3.2.1-11+squeeze4DSA-2315-1
openoffice.orgsource(unstable)1:3.3.0-1

Notes

Since 3.3.0 openoffice.org is a transitional source package to migrate to libreoffice

Search for package or bug name: Reporting problems