CVE-2011-2766

NameCVE-2011-2766
DescriptionThe FCGI (aka Fast CGI) module 0.70 through 0.73 for Perl, as used by CGI::Fast, uses environment variable values from one request during processing of a later request, which allows remote attackers to bypass authentication via crafted HTTP headers.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2327-1
NVD severityhigh (attack range: remote)
Debian Bugs607479
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libfcgi-perl (PTS)squeeze, squeeze (security)0.71-1+squeeze1fixed
wheezy0.74-1fixed
stretch, jessie, sid0.77-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libfcgi-perlsource(unstable)0.73-2high607479
libfcgi-perlsourcelenny(not affected)
libfcgi-perlsourcesqueeze0.71-1+squeeze1highDSA-2327-1

Notes

[lenny] - libfcgi-perl <not-affected> (Introduced in 0.70)

Search for package or bug name: Reporting problems