CVE-2011-2939

NameCVE-2011-2939
DescriptionOff-by-one error in the decode_xs function in Unicode/Unicode.xs in the Encode module before 2.44, as used in Perl before 5.15.6, might allow context-dependent attackers to cause a denial of service (memory corruption) via a crafted Unicode string, which triggers a heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs637376

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libencode-perl (PTS)stretch2.88-1fixed
buster3.00-1fixed
bullseye, sid3.08-1fixed
perl (PTS)stretch5.24.1-3+deb9u7fixed
stretch (security)5.24.1-3+deb9u5fixed
buster5.28.1-6+deb10u1fixed
bullseye5.32.1-2fixed
sid5.32.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libencode-perlsource(unstable)2.44-1low
perlsourcesqueeze5.10.1-17squeeze3
perlsource(unstable)5.12.4-4low637376

Notes

[lenny] - perl <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems